Jump to content


Ship Module Auto Upgrade Problem

mod questions

  • Please log in to reply
2 replies to this topic

SunshineAndHappiness #1 Posted 16 December 2016 - 01:29 AM

    Ensign

  • Players
  • 2
  • Member since:
    09-19-2016

I'm working on a mod to add heavy and light shield variants to the game. I'm having a problem where the auto-upgrade tool constantly tries to replace the normal shield with the heavy shield after any new ship modules are unlocked. I have to crank the volume/mass on the heavy shield higher than I'd like just to keep it from stripping out weapons in order to make the ship better defended.

 

Is there a way to hint/disincentivise the auto-upgrader to not favour this ship module so much? Or any other strategy, for that matter?

 

Thanks in advance.



Exoclyps #2 Posted 16 December 2016 - 08:25 AM

    Captain

  • Players
  • 351
  • Member since:
    11-04-2016
Have you tried increasing the cost? Haven't confirmed yet if that helps though, but worth checking out.

Had similar issues with xeno armor vs adamant armor where it kind of wanna downgrade to xeno (lower rank in the list), and figured maybe the fact it have half the cost caused the issue. Haven't been able to test things yet though.

SunshineAndHappiness #3 Posted 16 December 2016 - 11:31 PM

    Ensign

  • Players
  • 2
  • Member since:
    09-19-2016
Thanks for the idea. I bumped the cost from 12 to 120, but it was still as eager as ever to upgrade.





Also tagged with mod, questions

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users