Jump to content


Battle Leader Bonus Bug

Bug

  • Please log in to reply
1 reply to this topic

WhatIsSol #1 Posted 20 December 2016 - 10:36 AM

    Commander

  • Players
  • 123
  • Member since:
    03-04-2016

There is a bug in how the bonuses for leaders are being calculated.  Easy to see this in the battle damage.

Basically what the game is doing is calculating a damage bonus for a leader. The Bonus to damage is equal to 1. It then adds in the damage bonus of any leaders who have Weapon Max Damage bonus. Then if missile it adds in Missile Damage. If beam adds in Beam Damage. This final result is multiplied against the weapon damage

The bug is that when the combat is started it calculates these "leader" bonuses for your fleet. 

It checks if a leader is assigned, if they are it looks up their bonus. And then returns their bonus or 1 whichever is higher !!!!!!! <- BUG

If no leader is assigned it returns 1 !!!!!!!! <- BUG

So basically no leader is given you a 100% damage bonus. 

Actually if the leader is not given over 100% bonus they are worthless in a fight.

The fix is super simple - one line code change switching an assigned from 1 to 0.

 

Only difference in these videos is one has the leader bonus corrected so the damage is correct.

Leader Bonus Fixed -> http://www.orderofmi.../GoodLeader.mp4
54.8 version -> http://www.orderofmi...O/BadLeader.mp4

 

 


Edited by WhatIsSol, 20 December 2016 - 11:02 AM.


Exoclyps #2 Posted 20 December 2016 - 01:26 PM

    Captain

  • Players
  • 351
  • Member since:
    11-04-2016
This explains the steam post that someone made about double damage.





Also tagged with Bug

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users